Call Us: (740) 788-9000  |   Home  |   About Us  |   Customer Support  |   Downloads  |   News & Alerts

Internet Explorer Vulnerability 4/30/2014

Back to News

You may have heard of this new vulnerabilty from the news or seen it on the internet, and it is to be taken seriously. Microsoft has officially announced that all versions of Internet Explorer is unsafe to use unless you apply the update recently released. You can protect yourself by simply checking for updates and installing the updates. The update number is kb2879017 if you are checking for the specific update. If you are still using Windows XP, it is good to know that Microsoft has also released the update for Internet Explorer for you too. XP users will need to download it directly from the site listed below.

 

Microsoft Internet Explorer Vulnerability patch info/downloads - Click Here

Direct Download for Windows XP with Internet Explorer version 8 patch - Click Here

Microsoft's article about vulnerability - Click Here

Department of Homeland Security's article - Click Here